Saturday, April 26, 2008

» qtcurve-gtk2 was broken in KDE:Backports

The repository KDE:Backports was containing a package qtcurve-gtk2-0.59.0-3.1 that caused every single GTK2 application to crash on a buffer overflow (detected by glibc), including all of GNOME, firefox, thunderbird, etc... Thanks to a few bugreports on #suse, Dirk Müller quickly came up with a patch, fixed and rebuilt the package in the above mentioned repository (as well as in Factory). Of course, the patch was also sent to upstream. So just in case you run into that problem, just upgrade qtcurve-gtk2 to its latest version in KDE:Backports. And thanks to Dirk :)

Labels:

0 Comments:

Post a Comment

Links to this post:

Create a Link

<< Home